CP/M-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ Unofficial CP/M Website ] [ Z80 Family Support Page ] [ Forum-Regeln ] [ Impressum/Kontakt ]

CP/M-Forum » CPU-und Computer-Emulatoren » CP/M und Z-System auf dem YAZE-AG » Threadansicht

Autor Thread - Seiten: -1-
000
20.02.2005, 12:00 Uhr
Z-Helmut
Administrator
Avatar von Z-Helmut

Hi,

also hier geht es jetzt auf der Ebene CP/M und Z-System auf dem YAZE-AG Emulator weiter...

Ciao

Helmut
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
20.02.2005, 12:10 Uhr
Z-Helmut
Administrator
Avatar von Z-Helmut

Hi,

momentan gibt es noch "Probleme" unter Windows, bzw. unter Umgebungen, die kein X-WINDOWS Environment haben. Dazu gehört als erstes mal die Darstellung der Zeichen oberhalb von HEX-7F, also 127 ASCII. Diese sind notwendig, um Ümläute und Grafik darzustellen. Vor allem unter Windows mit seinem ANSI-Zeichensatz scheint das schwierig zu sein, wenn man die Original-Umgebung beläßt.

Anliegen 1 also: Block-Grafik und Umlaute korrekt darstellbar für Z-System
Anliegen 2 : Tastatur-Belegung eventuell ändern, daß die Pfeiltasten
Wordstar-Codes ^E,^X,^S,^D ausgeben.

Das alles wurde schon mal in MYZ80 gemacht, aber ich habe bereits diesem unkommunikativen Individuum namens Simeon Cran meinen Abschied erklärt, nachdem ich 10 Jahre lang versucht habe, MYZ80 in registrierter Form zu erwerben. Die Zukunft lautet eindeutig: YAZE-AG!

Gruß

Helmut
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
22.02.2005, 01:09 Uhr
Z-Helmut
Administrator
Avatar von Z-Helmut

Hi,

WINDOWS 98 COMMAND
neueste Erkenntnisse: auch wenn unter DOS ein ANSI Environment funktioniert,
dann wird nach dem Start von YAZE-AG dieses nicht mehr erkannt.

Prompt $e[0;72;"^E" hat Arrow-Up auf CTRL-E umgebogen unter "DOS".
NAch YAZE-AG start- weg! [A ist das Ergebnis.

Seltsamerweise wird sowohl im ZDE Editor und im dBase "Modify Command" Editor die Editier-Sequenz mit den Cursortasten richtig ausgewertet ...

Grübel ..

Ciao
Helmut
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
21.05.2006, 17:59 Uhr
almasys

Avatar von almasys

Liebes Forum,

das Problem der Tastaturbelegung muß bei YAZE-AG wohl das Terminalprogramm lösen - YAZE-AG verwendet einfach stdio.

Erfreut stellte ich fest, daß das Terminal von Mac OS X genau das kann, und zwar im Menü unter Terminal - Fenstereinstellungen... - Tastatur auswählen.

Jetzt kann ich mit den Cursortasten fuhrwerken wie es sich gehört.

ZDE versteht interessanterweise auch die Steuercodes des VT100-Terminals.

Viel Spaß wünscht
AlMaSys
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ CPU-und Computer-Emulatoren ]  



gaby.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek