CP/M-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ Unofficial CP/M Website ] [ Z80 Family Support Page ] [ Forum-Regeln ] [ Impressum/Kontakt ]

CP/M-Forum » CP/M 2.2 » Idee zu neuem CP/M ? » Threadansicht

Autor Thread - Seiten: -1-
000
06.09.2011, 22:15 Uhr
Hein_Ko

Avatar von Hein_Ko

Hallo Z80-Enthusiasten

Dies ist hier mein erster Post - mit gleich einer Grundsatzfrage:

Ich habe nun ein Z80-System mit BIOS und BASIC in Betrieb und würde gerne noch (wahlweise) ein CP/M2.2 implementieren. Da mein System kein Floppy unterstützt, jedoch CF/SD/SSD...über IDE, würde ein abgewandeltes CP/M sicher interessant sein, wenn man div. CP/M-Programme nutzen möchte.

Frage: Geht das überhaupt, ohne den ganzen CCP und BDOS-Teil zu zerpflücken? Oder sollte man da besser gleich ein neues CP/M schreiben?

Viele Grüße in die Runde
Heinrich
--
Es gibt keine Probleme - nur Lösungen !
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
07.09.2011, 13:37 Uhr
Ralph



Hallo Heinrich,

Na klaro geht das was Du willst. Du musst ja nur Dein BIOS anpassen. Schau doch Dir doch einfach mal das MLDOS als Basis für Deine Anpassungen an.
Du findest es nebst Quellcode und ne Menge weiterer fantastischer Anregungen auf der Homepage von Ralf (Susowa)http://susowa.homeftp.net/

Gruß Ralph
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
07.09.2011, 15:11 Uhr
Hein_Ko

Avatar von Hein_Ko

Hallo Ralph

Vielen Dank für Deinen Tip. Ich habe mir die PDF-Anleitung kurz angesehen. Es scheint, dass MLDOS genau richtig für dieses System wäre, auch wenn es kein K85 ist. Der Download ist jedoch für mich unbrauchbar, denn die Datei endet mit .PMA ??? Siehe ->

http://susowa.homeftp.net/index.php/download-topmenu/doc_download/233-mldos-15.html

Ich benötige jedoch Z80 Assembler Quellen, damit ich diese Version mit meinem BIOS "verheiraten" kann. Gibt es da noch eine andere Download-Möglichkeit oder andere Bezugsquellen?

Viele Grüße
Heinrich
--
Es gibt keine Probleme - nur Lösungen !
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
07.09.2011, 15:25 Uhr
Ralph



Das entpacken ist kein Problem Heinrich :-) Such Dir die Datei PMEXT.COM und Du kannst das PMA Archiv am PC entpacken :-)

Das Gute am MLDOS ist, die bereits enthaltene 16Bit Adressierung für das GIDE und es ist leicht verständlich

Gruß Ralph
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
07.09.2011, 15:43 Uhr
Hein_Ko

Avatar von Hein_Ko

Hallo Ralph

Nochmals Danke. Ich habe nun die Dateien entpackt. Da mein Crossassembler von AD.2500 diese Quellen nicht assembliert, bleibt noch die Frage, welcher Assembler bzw. IDE hierzu benötigt wird.

Grüße, Heinrich
--
Es gibt keine Probleme - nur Lösungen !
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
07.09.2011, 15:45 Uhr
Ralph



Heinrich ! ich hab Dir ne PN geschrieben
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
07.09.2011, 22:01 Uhr
maleuma



Hallo Heinrich,

Die ML-DOS-Quellen sind alle für CP/M-Assembler, z.B. M80.COM oder den SLR-Assembler.
Einen "vernünftigen" Assembler, der CP/M-Programme unter Windows erzeugen kann, habe ich bisher noch nicht gefunden - oder es sind umfangreiche Änderungen am Quellcode erforderlich, so wie Du es ja schreibst.

Also ich verwende da lieber einen CP/M-Emulator (z.B. MyZ80) unter Windows und lasse einen CP/M-Assembler laufen.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
07.09.2011, 22:40 Uhr
Hein_Ko

Avatar von Hein_Ko

Hallo Mario

Vielen Dank. Ich werde mir nun mal die Quellen genauer anschauen um zu sehen, was da alles von meinem BIOS her angepasst werden muss. Das sieht nach viel Arbeit aus... Winterprojekt?

Viele Grüße
Heinrich

... snip...

Hat jemand (für kleines Geld) einen funktionstüchtigen Kaypro4 abzugeben?
--
Es gibt keine Probleme - nur Lösungen !
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
07.09.2011, 23:47 Uhr
susowa




Zitat:
Hein_Ko postete
... welcher Assembler bzw. IDE hierzu benötigt wird.
Grüße, Heinrich

Siehe auch:

http://www.forum.z80.de/showtopic.php?threadid=417

Man bekommt den im Hintergrund arbeitenden Emulator gar nicht wirklich mit. Da man auch nichts hin- oder herkopieren muss, sondern direkt mit den CP/M-Assemblerquellen im Windows-Ordner arbeitet, ist das eine sehr elegante und komfortable Variante.

MfG Ralf
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
13.09.2011, 19:40 Uhr
maleuma



weitere Möglichkeiten sind noch hier beschrieben:

http://hc-ddr.hucki.net/wiki/doku.php/cpm:windows

allerdings suche auch ich noch die optimale Variante, die auch unter Win7x64 läuft.
Am besten eignet sich noch ZXCC: den SLR-Assembler kann ich aber auch nur bedingt damit einsetzen, da der SLR-Linker mit ZXCC nicht läuft.

Gruß Mario
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
14.09.2011, 09:01 Uhr
mtx500



Soweit ich mich erinnere:
Bei den SLR Programmen ist eine dem Käufer zugeordnete Seriennummer in der ausführbaren Datei eingetragen. Damit man die nicht einfach ändern kann gibt es da auch noch an anderer Stelle eine Prüfsumme über die Seriennummer. Der Algorithmus der die Seriennummer mit der Prüfsumme vergleicht nutzt zur Verschleierung "illegale" Z80 Befehle. Und diese werden nicht von jedem Z80 Emulator unterstützt.
Es gab auch spezielle Varianten der SLR Tools für den HD61480 / Z180, die diese "illegalen" Z80 Befehle nicht verwendeten, da diese ja im Z180 nicht implementiert sind. U.U. könnten diese Varianten im Emulator funktionieren.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
14.09.2011, 21:57 Uhr
maleuma



Also meine Version ist eine Z180-Implementation. Daran dürfte es demnach nicht liegen. Der Assembler läuft ja, nur der Linker nicht.
Demnach vermute ich eine nicht saubere Umsetzung im Emulator, z.B. wenn auf andere Dateien, z.B. Bibliotheken zugegriffen werden soll.

Mario

Dieser Post wurde am 14.09.2011 um 22:01 Uhr von maleuma editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ CP/M 2.2 ]  



gaby.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek